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All Creative Designs 
HTML Web Tutorial Using KompoZer  
Updated & extended Version July 2012 
 
Step 1 Download and Install KompoZer 
Step by step instructions to build a web page using 
KompoZer web editor. 
 
Easy web authoring  
KompoZer is a complete web authoring system that combines web file management and easy-
to-use WYSIWYG (What You See Is What You Get) web page editing. KompoZer is designed to 
be extremely easy to use, making it ideal for non-technical computer users who want to create 
an attractive, professional-looking web site. (Source: kompozer.net/features) 
 
If you a viewing the PDF version you might have to type or copy and paste address into your browser. 
Go To http://www.kompozer.net/download.php  Control click in MS Word Version 
For Windows operating system select version: 0.7.10 and click download (Figure 1) 
This version works fine on a Windows 7 (64bit) operating system. 

 
 
In the File Download Box (Figure 2) Click Save  

.  
 
 

Figure 1 

Figure 2 
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By default (Internet Explorer 9) will save the zipped installation files to the Downloads 
folder. After completed download locate kompozer-0.7.10-win32.zip right click and select 
Extract All… by default extracted (unzipped) files are saved into the same root folder, in 
this instance the Downloads folder (Figure 3).  
Note: The KompoZer web editor is a free standing (also called portable) application, which 
means that files don’t have to be installed into Windows program files and can be run from any 
folder on your computer or even your USB stick. 
 

 
If you like to change the folder location; click Browse and select a folder of your choice 
or create a new one in My Documents (Figure 4). 

 
 
.  
 
 

Figure 3 

Figure 4 
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Locate your extracted (unzipped) KompoZer folder and double click to open. 
There locate the KompoZer icon and double click (If security warning appears click run) 
and the interface will open. (Figure 5) 
 
 

 
 
To create a Short Cut Icon on your Desktop first: Right click KompoZer Icon > Send To 
> Desktop (create shortcut). (Figure 5 a) 

 
 
 
 
 

Figure 5 

Figure 5 a 

Deselect if you don’t want to Security Warning to show on every start up 
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Opening the Kompozer interface for the first time. 
KompoZer tips will show, you can read through the help tips or close the box and access 
the Help contents by pressing F1 on your keyboard at any time. Deselect the ‘Show tips 
at startup’ tick box to stop tips showing at every startup (Figure 6). 

 
 
KompoZer Interface Overview (Figure 7) 

 
 
 
 

Kompozer Interface 
Read through the help tips 
or click close. 

Figure 6 

Figure 7 

Make sure all bars are showing under  
View > Show/Hide in top Menu Bar. 
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Step 2 Opening an existing HTML document in KompoZer 
 
If you like to open an existing html document on your local drive or you have completed 
our Basic HTML tutorials read this step, otherwise go to step 3, 
Creating and saving a new HTML document. 
 
In KompoZer’s top menu bar click Open File and navigate to any of your existing 
index.html files stored on your computer, select and click open or 
open your my_first_webpage folder, select index.html and click open.  
(Figure 8) 
 

 
 
 
 
 
 
 
Next page contains information on how to toggle between different views. (Figure 9 a)

Figure 8 
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The web page we built in basic HTML tutorial 1 opens in KompoZer. (Figure 9 a) 
Use the toggle buttons and check and compare your source view. (Figure 9 b) 
 
  

 
 
 

Figure 9 a 

Figure 9 b 
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Kompozer did add a few extra tags to your index file the <tbody> table body tag 
appeared in line 8 and the closing </tbody> table body tag in line 19 wrapping all rows 
within your table tags. 
These tags are not necessary to display your web page correctly. 
Line 1 adds information about the html document version. 
 
The HTML toggle button will show tag information and can be helpful to understand 
table layout structure, but does not show table rows. 
 
 
Step 3 Creating and saving a new HTML document 
 
Creating a root folder for your web site. 
 
Open My Computer and create a folder in My Documents called local_sites (the main 
folder to store all your different web site projects), in this folder create a new folder and 
name it my_web_site or any term more fitting to your project, but remember no spaces 
in folder names, you can use capitals (MyPhotoWebsite). 
Click New Folder in My Documents or right click in white space and click New > Folder.  
The my_web_site folder will be the root folder for this project (Figure 10). 
 

 
 
 
 
 
 
 
 
 

Figure 10 
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KompoZer will create a blank document by default when starting the application. 
Saving your html document: 
In Menu bar select File > Save and then type the title for your home page, here you can 
use spaces, we call our example My Home Page. This title will be shown in the top of 
any internet browser. See figure 11 for explanation 
  

   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11 

1. Click Save under File in Menu Bar 

2. Type Page Title and click OK 
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Save Page As window appears under Save in: navigate to your root folder. 
(in this example called my_web_site) 
Change the file name to index.html or just index as KompoZer will add file extension 
automatically and click Save. (Figure 12) 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 12 

Change file name to index.html 
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Step 4 Creating a banner 
 
A. Inserting a table 
 
Tables, rows and cells are used for the layout of a web page; we will create a table that will show 
centered on monitor screens and at 900 pixels width will fit most screen resolutions including 
tablets without having to scroll left or right. 
 
To insert a table into the body of your web page click the TABLE button on toolbar. 
Insert Table window appears, click on the Precisely Tab and enter 1 under Rows and 1 
under columns. Under Width type 900 and select pixels in the drop-down menu. 
Leave the border setting at 1 if you desire a border or change to 0 for no border. 
Click OK. (Figure 13) 
 

 
 
Click within newly created table on the interface and then click the Table button on the 
toolbar again. (Figure 12 b) 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13 

Figure 12 b 
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1. Table Properties Box opens under the Cells Tab.  
Tick the box for Horizontal and select Center. 
 
2. Click on the Table Tab 
Under Table Tab change values for Spacing and Padding to 0 
Set Table Alignment to Center. 
Click OK (Figure 14) 
 

 
 
B. Saving a banner image 
 
We will insert a banner background using a CSS class style and a headline containing 
information about your web page into the table we created. 
What is (CSS) Cascading Style Sheets and why use it? 
Cascading Style Sheets (CSS) is a style sheet language describing the appearance (formatting) 
of an html document like background images, font styles and sizes. It is used; to decrease the 
amount of source code on a page allowing faster download speeds; to improve web browser 
compatibility; to enable multiple pages to share the same formatting; an increased range of 
formatting options and quicker synchronized updating of multiple web pages. 
If you like save a copy of your own banner background image into your web folder 
containing your index.html file. 
To use your own background image make sure it is 900 pixels wide by 150 pixels high 
(or between 120 to 200 pixels high depending on your requirement) and it is web 
optimized to a file size below 100 KB. See our Picasa Image Editing Tutorial (Freeware 
by Google) on how to crop and web optimize your own images. 
Only JPG, GIF and PNG image file formats will work! 
 
 
 

Figure 14 



Not to be copied or reproduced in any form without prior written permission by All Creative Designs® 

Copyright© 2012 Web Tutorial using KompoZer Part 1 by Peter Krisch All Creative Designs®  12 of 27 
 

 
Saving a background image for your banner 
 
Go to our web site > Gallery > Backgrounds Page 3 or control click link below: 
http://www.allcreativedesigns.com.au/pages/gallbackgrounds3.html 
If you a viewing the PDF version you might have to copy and paste address into your internet browser 
 
Choose a banner background image and left click on it to view the enlarged image. 
Right click the enlarged image and select Save picture as… 
Navigate to your web folder containing your index.html file and click Save.  
(Figure 15) 
 

 
 
Please note: All images on the All Creative Designs website are copyright and only to be used 
for study or private non business purposes. See copyright statement and more information on 
the All Creative Designs website at: 
 
 
http://www.allcreativedesigns.com.au/pages/acdCopyrights.html 
 
If you a viewing the PDF version you might have to copy and paste address into your browser. 
 
 
 
 
 
 
 
 

Figure 15 
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C. Inserting background image into table using CSS (Cascading Style Sheets) 
In the Kompozer interface under normal view select the table by clicking on it and then 
click the CSS editor button in toolbar. CSS Style sheets dialog box appears. Select style 
applied to all elements of class. Type a name for your style; remember no spaces in 
style names and click create style. Do not click OK yet! (See Figure 16) 
 

 
 
 
 
Do not click OK, continue reading next page. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 16  
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In the dialog box select the .mybanner style (1) and click on the background tab (2). 
Under the background tab click choose file (3), navigate to your my_web_site folder (4) 
and open your banner image (5). (Figure 17) 
 

 
 
 
 
 
Do not click OK, continue reading next page. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 17 



Not to be copied or reproduced in any form without prior written permission by All Creative Designs® 

Copyright© 2012 Web Tutorial using KompoZer Part 1 by Peter Krisch All Creative Designs®  15 of 27 
 

 
In the CSS Stylesheets dialog box under the background tab select don’t tile from the 
drop-down menu (1). Deselect the Image scrolls (2) and select Center and Top under 
Positioning (3). Click on the Box Tab and type 900px for width and 150px for height (4). 
Now click OK (5). (Figure 18)  
Adjust pixel height if using your own image at a different height. 

 
 
D.  Applying your Style 
Select your table by clicking on it (1) and then on the Formatting Toolbar select 
mybanner style from the drop-down list (2). Background image will appear.  
(Figure 19) 
 

 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar.

Background Tab 

Box Tab 

Figure 18 

Figure 19 
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If Background Image does not appear! 
If CSS style is not working or you made a mistake; 
(Click CSS Button on Tool Bar if CSS Styles dialog box is not showing) 
Select your style (1) and change parameters under the background or box tab. 
Make sure you are navigating to the right folder containing index and image files under Choose Files  
To delete style and start again: click the Red Cross Delete Button (2). 
 Then start again by clicking the CSS palette button (3).(Figure 20) 
 

 
 
 
 
 
E. Adding a Heading 
 
Click in your table and type a heading, select your heading (click and drag) (1). To apply 
a heading format select Heading 1 in Formatting Toolbar (2). 
(Figure 21) 
 
 

 
 
 
 
 
 
 
 
 

Figure 21 

Figure 20 
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F. Creating a CSS tag selector for Heading 1 (h1)  
 
Select your heading. 
Click the new CSS rule button (red circle) and under New Style rule select style applied 
to all elements (1). Type h1 (2) and click create style (3). Select your h1 style (4) and 
change to the Text tab (5), here select predefined and specify a font family, size and 
style, and other specifications (6), to commit click OK (7). (Figureb22) 

 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar.  
There are 3 different ways to apply CSS formatting called selectors: 
A class selector; which can be applied to any element (i.e. tables, rows, cells, images etc.) on 
your web page and is identified/prefixed by a dot; 

. (.mybanner) 
 
A tag selector (type element selector) will automatically change a specified tag  
(i.e. <h1> or <body> etc.) to the CSS formatting applied anywhere on your web page. It is 
prefixed by the tag itself;  
 
h1 or body 
 
An advanced or ID selector allows you to create individual styles by combining two or more 
styles and is prefixed by the hash key; 
 
#  (#content_table a:hover) 
 
Click Source in the Edit Mode Toolbar and locate your new CSS script in the head section of the 
source code. In between the brackets you find the formatting rules you have applied.  
 
Switch to normal view to continue this tutorial. 
 

Figure 22 



Not to be copied or reproduced in any form without prior written permission by All Creative Designs® 

Copyright© 2012 Web Tutorial using KompoZer Part 1 by Peter Krisch All Creative Designs®  18 of 27 
 

 
Viewing your web page 
 
To get a preview of your web page as it should look in an internet browser click Preview 
in the Kompozer interface. Click Normal Tab to return to working mode.(Figure 23 a) 

 
 
 
To view your web page in an internet browser like Windows Explorer or Firefox 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
Click Browse on Toolbar (1), click Launch Application when window appears, web page 
should open in your default internet browser (2). (Figure 23 b) 
 

 
 
 
Alternative 
In windows explorer (My Computer) navigate to your my_web_site folder and double left 
click your index.html file. Your web page should open in your default web browser i.e. 
Internet Explorer or Mozilla Fire Fox. 
 
 
 

Figure 23 a 

Figure 23 b 

Normal Mode 
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Step 5 Adding a Content Table 
In this step we will be adding a nested table to insert text, images and links. 
To do this we will insert a row below your banner into your existing table. 
 
A. Insert row into existing table 
Click in banner away from heading. Click Table in Menu Bar select and click Row Below. 
(Figure 24) 

 
B. Inserting a new table for content 
 
Click in your new row and then click Insert > Table on Menu Bar (Do not use Table 
Button on Tool Bar). In Insert Table dialog box select the Precisely Tab and enter 1 
under Rows and 3 for Columns, set the Width to 100 and select % of cell. Click OK. 
(Figure 25) 

 
 

Figure 24 

Figure 25 
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(If not selected; click within new table). Click the Table button on the Toolbar.  
(Figure 26) 
 

 
 
 
Under the Table Tab (1) change values for Spacing and Padding to 0. 
Leave other settings as they are. Click OK (3) 
 (Figure 27) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 26 

Figure 27 
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C. Setting cell width 
 
Click in first cell of your new table and click the Table Button on Tool Bar (1). 
Table Properties dialog box appears. Make sure the Cell Tab is selected and tick the 
width box and enter 120 under pixels (2).  Set Content Alignment to vertical Top and 
horizontal Center. Click Apply and then Next to select second cell. (Do not click OK) 
Tick width box and enter 600 for second cell then set Content Alignment as before (3). 
Click Apply and then Next to select third cell, tick width box and enter 180 for third cell 
then set Content Alignment as before (4). Click Apply then OK. (Figure 28) 
 

 
We have created a table with one row containing 3 cells at a specified width. We will use the first 
cell (to the left) to add an email link and a hyperlink to another website.  
 
D. Add E-mail link 
Click in the first cell and type Contact Us, click and drag to select. 
Click Link button on tool bar, type your e-mail address and tick box below it. 
Click OK. (Figure 29) 
Click Browse to view your web page in an internet browser and try out your e-mail link. 

 
 

Figure 28 

Figure 29 
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E. Add Link to other web site 
 
Click behind the Contact Us link, press enter on your keyboard then type Google 
and select. Click Link button and in the dialog box type http://www.google.com.au 
Under Target tick box and select in a new window to open Google website in new 
browser window and click OK. 
Link to any website in this way. (Figure 30) 
 

 
 
 
F. Adding text to your web page 
We will use the second cell (center) to add text.  
 
Click in center cell. 
Type text information relevant to your web page. Select any part of text and change font 
size, style or color on the Text formatting tool bar. (Figure 31) 
 

 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Read next page on how to copy and paste text. 
 
 
 

Figure 30 

Figure 31 
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If you like to copy and paste text into your web page; 
Don’t copy straight from a word processor like MS Word.  
Copy your text from the word document and paste it into Notepad, copy it from there 
again and paste into your web page by clicking in cell where text is to be placed then 
right click and choose paste. 
Find Notepad under All Programs > Accessories on your computer. (Figure 32) 
 
 

 
 
 
 
Remember to save your web page by clicking save under the File menu in top menu bar 
or use Save button in toolbar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 32 
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G. Saving an image for your web page 
We will use the third cell (right) to add images.  
Using your own images: 
Any images should be no larger than 150 pixels wide by 180 pixels high for this purpose and be 
web optimized. Only JPG, GIF and PNG image file formats will work. 
See our Picasa Image editing tutorial for editing and web optimizing your own images. 
 
Saving an image for your web page from our web site. 
Go to our web site > Gallery > Animals or control click link below: 
http://www.allcreativedesigns.com.au/pages/gallanimals_amphibians.html 
If you a viewing the PDF version you might have type or copy and paste address into your browser. 
 
Right click any small image and select Save picture as navigate to your web folder 
containing your index.html file and click Save. (Figure 33) 
 

 
 
Please note: All images on the All Creative Designs website are copyright, watermarked and 
only to be used for study or private non business purposes. See copyright statement and more 
information on the All Creative Designs website at: 
http://www.allcreativedesigns.com.au/pages/acdCopyrights.html 
If you a viewing the PDF version you might have type or copy and paste address into your browser. 
 
Please contact us if you want to use our images on your commercial website: 
Email All Creative Designs   
enquiries@allcreativedesigns.com.au 
If you a viewing the PDF version you might have to type or copy and paste email address into mail client. 
 
 
 
 
 
 
 

Figure 33 



Not to be copied or reproduced in any form without prior written permission by All Creative Designs® 

Copyright© 2012 Web Tutorial using KompoZer Part 1 by Peter Krisch All Creative Designs®  25 of 27 
 

 
H. Inserting the image 
 
Click in right hand cell (1). 
Click the Image Button in the Tool Bar (2) and the Image Property Box will open.  
Click the choose file button (3)  
Under Look in: navigate to your web folder, there select your image and click Open (4).  
Add an image description under Alternate Text. (Spaces and capitals allowed) 
Click OK in the Image Property Box. (Figure 34) 
 
 

 
 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Inserting a second image 
 
Follow steps above and save another thumbnail image into your web folder. 
Click on right hand side of first inserted image and press enter on your keyboard. Click 
image button and repeat the process. 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Image resizing and web optimization of your own images is explained in our image 
editing tutorials. (See links at end of tutorial) 
 
 
 
 
 
 

Figure 34 
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I. Add background color to cells 
 
Click in cell with the inserted images (on white space not on images themselves) and 
then click the Table button in the tool bar. 
Table Properties box opens under Cells tab click button right next to Background Color. 
Select a cell background color suiting your design and click Apply, try out different color 
and click Apply, when suited click OK. 
(Figure 35) 
 

 
 
 
You might like to repeat the process for other cells. 
 
Save your web page by clicking save under the File menu in top menu bar or use Save 
button in toolbar. 
 
Viewing your web page 
 
Click Browse in Tool Bar or: 
In My Computer navigate to your my_web_site folder and double left click your 
index.html file. Your web page should open in your default web browser i.e. Internet 
Explorer or Mozilla Fire Fox. 
 
 
 
Your finished page should look similar to this. (See next page) 
 
 
 

Figure 35 
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Other tutorials available from www.allcreativedesigns.com.au  
You might have to type or copy and paste this address into your browser if viewing the PDF version 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp1.html 
New Version 2012 HTML Web Page Tutorial using Notepad, PDF Download Page Part 1 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp2.html 
HTML Web Page Tutorial using Notepad, PDF Download Page Part 2 
 
www.allcreativedesigns.com.au/pages/tutorialbasicp3.html 
Free PDF HTML Tag Tutorial using Notepad, Download Page Part 3 
 
www.allcreativedesigns.com.au/pages/webtutorialkompozer.html 
Web Design Tutorial using KompoZer, PDF Download Page 
 
www.allcreativedesigns.com.au/pages/tutorialpicasa.html 
Picasa Photo Editing Tutorial, Free PDF Download Page 
 
www.allcreativedesigns.com.au/pages/tutorialseo.html 
New Version 2012 SEO Tutorial Basic Search Engine Optimization Download Page 
 
Trouble Shooting 
 
My images will not show if: 
 
1. Images are not saved in the same folder as your index.html file 
2. Spelling mistakes or spaces in file names  
3. Wrong file extension i.e. .jpg instead of .gif 
4. Copied file names from MS Word 
 
Please contact us if you like to comment on this tutorial: 
Email All Creative Designs   enquiries@allcreativedesigns.com.au 
 
Please consider a donation to www.kompozer.net   

X 


